Command timeout expired / De maximale tijdsduur voor het uitvoeren van de opdracht is verstreken
Je krijgt deze melding bij:
- Het genereren van een analyse, document of rapport (ook bijvoorbeeld een loonstrook, factuur of rapportenset).
- Het aanroepen van een connector.
- Het exporteren van een weergave.
- Het importeren van een CAO Update.
- Het openen van een weergave.
Oorzaak
Deze melding krijg je als er teveel data wordt opgehaald.
Oplossing
Krijg je deze melding bij een rapport of loonstrook?
Je lost de melding op door het rapport of document bijvoorbeeld in 2 delen te genereren. Ook kan je proberen de afbeeldingen in het rapport te verkleinen of te verwijderen. Bij het genereren van loonstroken kies je in de Salarisverwerkingscockpit voor de actie Output. Daar kies je voor Loonstrook. Vervolgens kun je filteren op een deel van de medewerkers, zodat je de loonstroken in 2 delen kunt genereren. Houd er wel rekening mee dat als medewerkers de loonstrook al wel hebben ontvangen én de verstrekkingswijze bij hen op Bericht staat, ze nogmaals een bericht krijgen.
Krijg je deze melding bij het importeren van een bestand, of het importeren van een CAO Update?
Log eerst uit via Ctrl + F1 en start Profit vervolgens opnieuw op. Importeer het bestand nogmaals. Krijg je deze melding bij een CAO Update? Importeer de CAO Update opnieuw in Profit. Blijft de melding komen en wil je de update importeren om als nieuwe cao te gebruiken? Stuur dan een incident in bij Support om de update door AFAS in de omgeving te laten zetten.
Krijg je deze melding bij een GetConnector?
Gebruik de tips uit het artikel GetConnector geeft melding Out of memory om alleen relevante data op te halen. Gebruik het artikel Performance van GetConnector optimaliseren om de data vervolgens op een zo snel mogelijke manier op te halen voor een optimale performance.
Krijg je deze melding bij het factureren van concepten/abonnementen?
Ik krijg bij het factureren van concepten/abonnementen een foutmelding. Daarna lijken mijn concepten/abonnementen weg en zijn deze niet te vinden in het facturenoverzicht. Voor meer informatie, zie dit artikel.
Krijg je deze melding bij het openen van een weergave?
Log eerst uit via Ctrl + F1 en start Profit vervolgens opnieuw op. Lost dit het probleem niet op? Blokkeer of verwijder dan de weergave en voeg een nieuwe weergave toe.