Er is een onverwachte fout opgetreden (8013:1537). Unexpected token at offset X
Je krijgt deze melding bij het verzenden van een e-mail vanuit Profit.
Oorzaak
Deze melding krijg je als er een typefout zit in het e-mailadres van de afzender of ontvanger. Dit kan een spatie te veel zijn of een enter die vanuit het kopiëren van het e-mailadres is meegekomen.
De melding kan er als volgt uitzien:
Description...........: Unexpected token at offset XX
Number................: -2146233033 #80131537
Init state............: Saved
Source................: MimeKit
Time..................: 21-04-2023 09:49:03.739
DLL/EXE file..........: AMailObj
Session...............: AFAS\SVC_ComSupport on AFAS\SUPS2PAS01 (NoTS)
----------------------
Landmark..............: AntaEMailObject.modGeneral.CreateEmailAddress [672F0C04]
PAR: parEMailAddress..: email@enyoi.nl
----------------------
Landmark..............: AntaEMailObject.modGeneral.CreateAntaEmail [672F0E85]
----------------------
Landmark..............: AntaEMailObject.AntaEMail.SaveEmailToFile [70FE2154]
Oplossing
Je lost de melding op door in de detailmelding achter de tekst parEMailAddress te controleren om welk e-mailadres het gaat (zie hierboven). Vul dit e-mailadres handmatig opnieuw in om te zorgen dat er geen verborgen of vreemd teken meekomt.
Is het e-mailadres van de afzender? Controleer aan de hand van het artikel Waar in Profit stel ik de afzender van een e-mailbericht in? op welke plekken je het e-mailadres corrigeert. Is het e-mailadres van de ontvanger? Corrigeer het e-mailadres in de eigenschappen van de medewerker of persoon.
Lees ook het artikel Hoe lees ik een foutmelding? Als je weet hoe je een foutmelding kan lezen, kan je voortaan zelfstandig meldingen oplossen. Lukt het toch niet om de melding op te lossen? Stuur dan een incident in via de AFAS Klantportal. Kopieer de volledige detailmelding en stuur deze mee in het incident.