De opgegeven UPN kan niet worden gebruikt, omdat deze al wordt gebruikt om iemand anders te identificeren. Kies een andere UPN en probeer opnieuw
Je krijgt deze melding bij het aanmaken van een nieuwe gebruiker in de Autorisatie tool of bij het aanmaken van een sollicitant (waarbij automatisch een gebruiker wordt aangemaakt).
Oorzaak
Deze melding krijg je als je bij het aanmaken van een nieuwe gebruiker een UPN invult die al in gebruik is bij een andere gebruiker binnen dezelfde licentie.
Inhoud |
Oplossing in productie-omgevingen
Je lost de melding op door in ALLE omgevingen (inclusief test- en Accept-omgevingen) te controleren of er een gebruiker actief is met deze UPN. Je benadert deze omgevingen via een aparte tegel (zie afbeelding). De UPN moet voor elke gebruiker uniek zijn. De UPN mag dus niet al worden gebruikt bij een andere gebruiker.
Komt de gebruiker die je probeert aan te maken al voor in een andere omgeving? Zorg ervoor dat de gebruikerscode bij alle gebruikers hetzelfde is. Wijzig in dat geval één van de gebruikerscodes, zodat de gebruikerscodes in alle omgevingen hetzelfde zijn.
Voorbeeld:
Je hebt een actieve gebruiker in de omgeving O12345AA die je ook toegang wilt geven tot de omgeving O12345AB voor het inloggen op een OutSite pagina. Bij het verstrekken van de portaltoegang in de AB omgeving krijg je de melding.
Hoe los je dit op?
Kijk in de O12345AA omgeving naar de gebruikerscode van de gebruiker.
Ga vervolgens naar de O12345AB omgeving (de omgeving waar je de gebruiker toegang wilt verlenen voor OutSite).
Maak hier een nieuwe gebruiker aan met dezelfde gebruikerscode als in omgeving O12345AA omgeving.
Vervolgens kan je via de eigenschappen van de contactpersoon de gebruiker portaltoegang geven.
Komt de melding bij het aanmaken van een sollicitant en bestaat deze al in Profit (ook als gebruiker)? Kies dan op InSite in de sollicitatie voor Aanpassen en vul in het veld Keuze bestaand persoon de sollicitant die al bestaat.
Meer informatie hierover lees je in het artikel Gebruikerscode wijzigen.
Oplossing in testomgevingen
De bovenstaande oplossing geldt ook in testomgevingen. Hierbij kan het echter voorkomen, dat de gewenste gebruiker nog niet in de testomgeving aanwezig is.
Oplossing:
- Open de productieomgeving.
- Achterhaal de gebruikersnaam van de gebruiker, bijvoorbeeld 12345.Robert.
- Open de testomgeving.
- Volg een systeemgebruiker toe met de gebruikersnaam van stap 2, dus bijvoorbeeld 12345.Robert.
- Zet de nieuwe systeemgebruiker om naar een gewone gebruiker.