ActiveX component can't create object

You can get this notification in various places in Profit Windows.

Cause

The cause of this message often has to do with the functioning of the application server.

Solution

AFAS Online

Do you get this message? Send an incident to Support with the full details report, so that Support can transfer the incident to the AFAS Online team.

Then close Profit forcibly via the key combination CTRL + F1. Then choose Logout or Sign out. After Profit is closed, open Profit again. You are now logged on to a different server, so you can continue working without problems.

Can't log out via the key combination? Then log out via the steps below:

  1. Open the hidden icons tray in your taskbar.
  2. Right click on Citrix Receiver.
  3. Click on Connection Center.

  4. Click on the XENAPP folder and then on Log Off.

Local installation

You resolve the message by terminating the 'DLLHOST.EXE' on the application server where Profit is installed. Your system administrator can help you with this.

  1. Check if any users are logged in to Profit. ALL users must be logged out.
  2. Start Windows Task Manager
  3. End the "DLLHOST.EXE" process.

Then check whether the error message still occurs. If so, then perform a Profit COM + reinstallation.

Directly to

  1. Logging into AFAS Online
  2. Logging into AFAS Online for the first time using two-factor authentication.
  3. Logging in with AFAS Pocket using a unique number
  4. Signing on by means of two-factor authentication
  5. Switching the authentication method
  6. Forgotten my telephone in relation to two-factor authentication
  7. Using a web version instead of Citrix Receiver
  8. Change personal data/I have a new phone
  9. Signing on by means of Single sign-on
  10. Logging in through text messaging will stop as of 1-1-2022