ActiveX component can't create object
You can get this notification in various places in Profit Windows.
Cause
The cause of this message often has to do with the functioning of the application server.
Solution
AFAS Online
Do you get this message? Send an incident to Support with the full details report, so that Support can transfer the incident to the AFAS Online team.
Then close Profit forcibly via the key combination CTRL + F1. Then choose Logout or Sign out. After Profit is closed, open Profit again. You are now logged on to a different server, so you can continue working without problems.
Can't log out via the key combination? Then log out via the steps below:
- Open the hidden icons tray in your taskbar.
- Right click on Citrix Receiver.
- Click on Connection Center.

- Click on the XENAPP folder and then on Log Off.
Local installation
You resolve the message by terminating the 'DLLHOST.EXE' on the application server where Profit is installed. Your system administrator can help you with this.
- Check if any users are logged in to Profit. ALL users must be logged out.
- Start Windows Task Manager
- End the "DLLHOST.EXE" process.
Then check whether the error message still occurs. If so, then perform a Profit COM + reinstallation.